Pix

Start PixWriter

Click the Start menu. Click PixWriter 3 in the
Programs menu.

Make a PixWriter Word Bank

1. Make Buttons
Type a word and press spacebar to make a button.
Repeat for each desired word.
Note: Capitalize proper nouns and “I”.
Note: To duplicate a button, hold Shift and click the
desired button.
Note: For Spanish language — select Spanish in the
Options menu then type your Spanish words.

2. Clear the Paper
Press the Escape key to clear the paper at any time.

3. Organlze the Buttons (Optional)
+ Hold Shift and drag a button to move it.
+ Hold Shift key and drag and drop a button on top
of another button to swap positions.
+ Hold Control (ctrl) and click a button to delete it.

4. Color Button Borders (Optional)
A. Hold down the Alt key and click the desired color
in the palette.
B. Continue holding down the Alt key and click a
button to change the border color.
To change back to a black border: hold the Shift and
Alt keys simultaneously then click the button.

5. Lock the Word Bank (Optional)
The last preparation step is to lock the Word Bank.
Click the lock button in the toolbar. This will prevent
accidental changes to the Word Bank. To Unlock, use
the Edit menu or Control + L.
Note: The keyboard is always active.

6. Save the Word Bank

Use Save As in the File menu to save the Word Bank
in the desired location.

Wrzter Quick Reference - WIN

1. Type word, press space to make button

“*sports organized and colors - PixWriter
File Edit Options Speech Help
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2. Press escape to clear paper

3. Shift and drag to move buttons
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4. Alt + Click color and button for color border
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5. Lock Word Bank J | g
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Quick Reference: Writing with PixWriter 3.WOW

12 spors - pcrer L Ox
Write with PixWriter 3 Ways PR @
\ . y - . &g, S @iﬁ <

1. Mouse, touch window, joystick or similar device @/ﬁ. .

Click on any button to write the picture/word on the Sportsl My favorite s

paper.
2. Keyboard

Just type and press space bar to put words on the Ewom SERNE oI G

paper. ,, - C

Note: Lock Word Bank to prevent changes to buttons. ﬂ . ,"3 E..

Can also Hide Word Bank and just use the keyboard. o & ..
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3. Switches- See page 5 Iﬂ

A. Single switch scan | V) litike BRennisfiootbal

B.Two Switch stepscan e mcmmmmmmaao.
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Punctuation, Return, Erase & Speak Buttons = ~coccc—co—co—-co--e - om0
PixWriter Tool Bar —Qpﬂons | Options |

The Punctuation, Return, Erase, and Speak buttons are Soeak Button Bi v Speak Button Big

located in the Tool Bar when you first start PixWriter. Efase Butbon B.lgg v Erase Button Big

. . Punctuation Big v Punctuation Big

Big Punctuation, Speak and Erase Buttons

Go to Options menu, and select Punctuation Big, Speak
Button Big and/or Erase Button Big.

Note: You can choose them individually.

Note: 4 Button Word Bank limited to Big Speak only.

PixWriter will place the buttons in the last spaces in the S HEEE g &3:\{3' ..M ‘
Word Bank. TYA«Q ¥R D @ ‘A{&#@ﬁ
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Editing a PixWriter document 2| o e | e |
Delete a Word:

1. Click the word you want to delete

- Y& ¥y e
2. Click the Erase button. S O % % ;;V% 1
The sun shines | [T The sun_shines

-~

Substitute One Word for Another:
1. Click the word you want to change.

2. Click the new desired word button. € 9 %“' € §
The birds The birds sing

Add/Insert Missing Punctuation:
1. Click the word that will precede the punctuation.

2. Click the desired punctuation. < § g;(’j? ;
PixWriter will insert the punctuation, properly space after The birds B the sun (I
the punctuation and capitalize the first word in the next

sentence (after . ? ). < § ;ﬁ)}

The birds sing! The sun

Insert a Word:
1. Click the word that will follow the inserted word.

2. Hold down Alt and click the word in the Word Bank i Alt + {gijg & 9
you wish to insert. The A The sun _shines

PixWiriter 5. WOW Quick Reference Guide- Windows (Rev 0508) © Copyright 2008 Slater Software, Inc. 2



Quick Reference: Customizing a PixWriter 3.WOW Word Bank

Select Number of Buttons in Word Bank Qptions |
1. Go to Options menu. 4 Buttons
2. Select 4, 16, 36 or 64 button Word Bank. . e paene

Note: the default Word Bank is 36 buttons. 64 Buttons

£ furniture 16 - PixWriter - |C “*furniture 36 - Pi wmer ElE < ur niture 64 b - wamer
File Edit_Options _Speech Help el
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furniture table couch recliner
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. . Options
Change Size of Pictures on the Paper: P :
1. Select Smaller Pictures (Ctrl 1) or Larger Pictures Smaller Pictures Ctrl+1
(Ctrl 2) in the Options menu. Larger Pictures Curl+2

2. Repeat to get the desired size pictures. E;:!fr_rz;"t g;::i
Change Size of Words on the Paper: t

1. Select Smaller Text (Ctrl 3) or Larger Text (Ctrl 4) in i%l

the Options menu. = i
2. Repeat to get the desired sized words. f i % I
Table il b Table

Change Font: _ _ Ctrl + 1 Ctrl + 2 Ctrl +3 Ctrl + 4

Select Font in the Options menu. This opens the font

properties. Select desired font. This changes the font 7m| ﬁ'

on the paper. To change the f_ont on theT buttons, select - Pictures on Buttons Pictures on Buttons
Sync Document/Button Font in the Options menu. : — TR — e

Pictures on Buttons (on/off):
1. Go to the Options menu. There is a check in front
of Pictures on Buttons.
2. Select Pictures on Buttons to turn off. When off,
there is no check in front of Pictures on Buttons.
3. Select Pictures on Buttons again to turn on.

1= /A] ¢ w02 EANELDLI0

head | shoulder arm | elbow | wrist | hand | thumb  fingers:

neck | back | leg | thigh | knee ' ankle | foot  toes

Opti Opti
Hide/Show Word Bank: Options | Options

1. Go to Options menu and select Hide Word Bank to Show Word Bank Hide Word Bank
hide the buttons. Use the keyboard to write. The — A1 T C—
Punctuation, Return, Erase and Speak buttons
remain on the screen and may be used.

2. Go to Options menu and select Show Word Bank
to use the buttons, again.

Spanish Language:
Select Spanish in the Options menu. Enter Spanish
words to make buttons. Options |

e 0L ORNE o0

English

Lock Button Setup: v Spanish

Select Lock Word Bank in the Edit menu or click the

Lock button on the PixWriter Tool Bar. When the Word
Bank is locked, typing on the keyboard does not make
new buttons. Unlock the Word Bank in the Edit menu -
or use Ctrl L to make changes to the Word Bank.

IENELIO
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Quick Reference: Target Words and Import Pictures

Target Words - What are they?
Any time you want to change a picture - word match/
use, you will target the word used in the document.
PixWriter uses Literacy Support Pictures™ (LSP™)
from Slater Software.

Target Word - Things you can do
A. Change picture/word match
Use a different picture in the LSP library
Remove a picture from appearing
Import pictures to use with words (see pg. 5)
B. Change text-to-speech pronunciations
C. Make a button with 2 or more words

How to Change image for Target Word
1. Click the Target button on the Tool Bar.
2. Enter the desired word in the Target Word box.
3. Enter the Alternate Word. (from LSP Library).
4. Click Add Target to use that image.
5. Click Done when you are finished making Target
Words.

Using the LSP Thesaurus:
1. When you enter a Target Word, all appropriate LSP

will automatically appear in the thumbnail
boxes.

. Click any alternate picture to select it.

. Click Add Target to use that image.

. Click Done when you are finished making Target
Words.

HWN

Make a Phrase or Sentence Button
1. Enter 2 or more words in the Target Word box.
a. If the phrase has an LSP (is in the Library), the
picture will appear.
*Note: See page 6 for another way to make a phrase
button for phrases with an LSP.
b. If the phrase is not in the library, enter the name
of an alternate image to use or import a picture.
2. Click Add Target.
3. Click Done when you are finished making Target
Words.

Target Word Basics

1. Click Target Button in Tool Bar

2. Enter the Target

3. Enter the Alternate Word

N

4. Click Add Target.

Word
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Targer

werds
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5. Click Done.

LSP Thesaurus

1. Enter the Target Word

2. Click alternate picture
X

Target Words
- s

1b phrase not in library

— Eor 3 vord o pivase, seiec DA s agR, MG POARGSIGN s 0dd et
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examples examples

thank you | see the

stop sign my turn

Abraham Lincoln boys and girls

crystal ball It’s time to

cowboy boots shopping list
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Quick Reference: Import Pictures, continued; Scanning with Switches

Import Picture on Clipboard - Target Word
. Copy a picture to your clipboard.

. Click Target button in the Tool Bar.

. Enter Target Word.

. Click Clipboard Thumbnail.

. Click Add Target.

. Click Done.

OO WN—=

Import Picture on Clipboard - to Document
1. Copy a picture to your clipboard.
2. Type word on the page or click a button to write it.
3. Click the picture above the word on the paper.
4. Select Paste in the Edit menu or use Ctrl V.
Note: Word must have a standard LSP for this to work.

Writing with Switches
Refer to the instructions for your Switch Interface to
select Key Characters (the key signal sent by the
switch).
1. Select Setup Scan... in the Options menu.
2. Choose Single Switch or Two Switch Step Scan.
3.Single Switch Scan - select scan time in seconds
with the Advance Timer scale.
4. Enter Key Characters for Switches.
5. Select Scan Options:
a. Auditory Scan announces each scanned button.
b. Tick Sound on Advance is a soft tick sound as
the highlighter moves.
C. Groups highlights groups of buttons first, then
highlights the items within the selected group.
d. Start Scan with Speak Button. Big Speak Button
must be in the Word Bank.
Note: Select Big Punctuation, Big Speak &/or Big Erase
to use those functions with switches.
Note: 4 Button Word Bank uses Big Speak only.

Turn Scan On/Off

1. Return to Setup Scan in the Options menu. Click
Scanning Off.

2. Use Toggle Scan On/Off in the Options menu or
press Ctrl =.

@ Import Picture Target Word

[ Target Words [5<) [ Target words &

SOl NERNE 210 i O W RN L0

fawn fawn

“*import fawn to doc - PixWriter
Fle Edt

RANE L0

Options |

Setup Scan... F8

Toggle Scan On/Off Ctrl+= or F7
e ——
Setup Scanning B]
Sean Aston
e Scannng O
Sung's Getch Seancieg @ 159y Chesncies Seleces
Slpeege Acfunscp Timee Pt
Twis Smiich Shap Scas 2l Ky CRasnaaior A /nns
141 Kiry Characssr Simm somnneng it SPEAK o Tick Sownd on Advance
Dot Ky Chavnstin Geowps Ausdiney Scanmng
Cancal I i
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Quick Reference: Advanced Teacher

Using the Phrase Edit Box
in the Tool Bar

Make Word Bank by Power Typing
1. Click the Phrase Edit box in PixWriter Tool Bar.
2. Type the desired words in the Phrase Edit box.
3. Click the Get Pictures button in the Tool Bar.
4. PixWriter makes the buttons for the words.

Make Word Bank from Electronic Text
1. Copy text from any electronic source to get it on the
computer clipboard.
. Click the Phrase Edit box in the PixWriter Tool Bar.
. Select Paste (Ctrl V) in the Edit menu.
. Click the Get Pictures button.
. PixWriter will create all of the buttons at once.

Gar~rWN

Make a Phrase Button
1. Click the Phrase Edit box in the PixWriter Tool Bar.
2. Type the desired phrase.
3. Click the Get Pictures button.
a. If the phrase has an LSP in the Library, one
button will be made, e.g. stop sign.
b. If the phrase is not in the library, a button will be
made for each word in the phrase, e.g. school
bus.

Make Duplicate Buttons
Duplicate word buttons are very useful. Example: put
the words in sentence order to scaffold beginning
writers.
1. Enter the desired words.
2. Shift + Click a button to duplicate it.
3. Shift + drag the buttons to position them.

PixCards™

Make small picture cards that students can use for

communication, to request words for a Word Bank, to

play a game, to label the environment, etc. A student

could also use these pictures for story dictation.

1. Enter the desired words in PixWriter.

2. Select PixCards in the Options menu to create
PixCards.

3. Adjust the picture and word size using the Options
menu.

4. Print and use.

5. Turn PixCards off by selecting PixCards in the

Options menu again.

fireman policeman librarian teacher principal lawyer
bkanker barber accountant secretary doctor nurse

“phrase edit toxt - PixWriter

“phrase edit text - PixWriter
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Some planets can be seen in the night sky.
%ometimes you can see them without a telescope.
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b )
8.00 Go to classroom.
B¢
8:05  Put backpack away
e O J[@ls

800 | 810 |st

@) )

sssssssss

Options

Smaller Pictures Ctrl+1
Larger Pictures Ctrl+2
Smaller Text Ctrl+3
Larger Text Ctrl+4
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